600354股票 通达信黑马大黑马指标公式

600354股票 通达信黑马大黑马指标公式

600354股票 通达信黑马大黑马指标公式

{庄家吸筹}
MA15:=EMA(CLOSE,21);
VAR11:=IF(YEAR>=2038 AND MONTH>=1,0,1);
VAR21:=REF(LOW,1)*VAR11;
VAR31:=SMA(ABS(LOW-VAR21

600354股票

),3,1)/SMA(MAX(LOW-VAR21,0),3,1)*100*VAR11;
VAR41:=EMA(IF(CLOSE*1.3,VAR31*10,VAR31/10),3)*VAR11;
VAR51:=LLV(LOW,30)*VAR11;
VAR61:=HHV(VAR41,30)*VAR11;
VAR71:=IF(MA(CLOSE,58),1,0)*VAR11;
VAR81:=EMA(IF(LOW<=VAR51,(VAR41+VAR61*2)/2,0),3)/618*VAR71*VAR11;
主力吸筹22:IF(VAR81>100,100,VAR81)*VAR11,COLORFF00FF;
庄家吸筹22:STICKLINE(主力吸筹22>-150,0,主力吸筹22,1,0),COLORFF00FF;
A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,2)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,2);
牛线:EMA(A1,5),LINETHICK1,COLORYELLOW;
熊线:100-EMA(A1,5),LINETHICK1,COLOR00FF00;
A2:=(牛线-REF(牛线,1))/REF(牛线,1)*100;
A3:=EMA(C,5);
A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
猴线:(EMA(4*SMA(A4,6,1)-3*SMA(SMA(A4,5,1),5,1),2)),LINETHICK1,COLORRED;
庄家吸筹1:STICKLINE(猴线>100,100,猴线,1,0),COLORGREEN;
庄家吸筹2:STICKLINE(猴线<0,0,猴线,1,0),COLORGREEN;
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
DRAWTEXT(FILTER(REF(牛线,1)>90 AND A2<0,7),牛线,'跑'),COLOR00FF00;
DRAWTEXT(CROSS(猴线,牛线)AND 牛线>20 AND 牛线<A5,牛线,'黑马');
DRAWTEXT(CROSS(猴线,0)AND 牛线<40,5,'大黑马');
底部:(A2<-10 AND A2>REF(A2,1))*25,COLORRED;
机会来临:REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1),LINETHICK2,COLORE66878;
大势已去:IF(CROSS(牛线,A1)AND 牛线>70 AND 猴线>80,90,100),LINETHICK2,COLORE66878;
DRAWTEXT(CROSS(猴线,牛线)AND 牛线>20 AND 牛线<A5 AND 底部,牛线,'骑马找牛');
A:=CROSS(猴线,牛线) AND CROSS(猴线,熊线);
B:=CROSS(猴线,牛线) AND CROSS(牛线,熊线);
DRAWTEXT(A AND B,牛线,'骑马找牛');
50,LINETHICK3,COLORE66878,POINTDOT;
牛市开始:=CROSS(牛线,熊线);
DRAWTEXT(牛市开始,熊线,'牛市');
马市开始:=CROSS(猴线,熊线);
DRAWTEXT(马市开始,熊线,'马市');
猴市开始:=CROSS(猴线,牛线);
DRAWTEXT(猴市开始,牛线,'猴市');
DRAWTEXT(ISLASTBAR,牛线,' 牛线'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,熊线,' 熊线'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,猴线,' 猴线'),COLORYELLOW;
-6,,LINETHICK0;